Welcome to MonsterMegs' status page. If you want to keep on top of any disruptions in service to our website, control panel, or hosting platform, this is the page to check. We report minor/major outages and scheduled maintenance to this status page. However, issues affecting a small number of customers may be reported directly to affected customers in MyMonsterMegs (https://my.monstermegs.com). If you're experiencing an issue you do not see reported on this page, please log into MyMonsterMegs to view any alerts our team has added to your account.
Router Maintenance Window
Completed
Scheduled for February 03, 2026 at 7:00 AM – 8:00 AM
Affects
Web Hosting Servers
Under maintenance from 7:00 AM to 8:00 AM
Storm
Under maintenance from 7:00 AM to 8:00 AM
Thunder
Under maintenance from 7:00 AM to 8:00 AM
Updates
Completed
February 03, 2026 at 8:00 AM
Completed
February 03, 2026 at 8:00 AM
Maintenance has completed successfully
In progress
February 03, 2026 at 7:00 AM
In progress
February 03, 2026 at 7:00 AM
Maintenance is now in progress
Planned
February 03, 2026 at 7:00 AM
Planned
February 03, 2026 at 7:00 AM
Estimated Maintenance Window: 10 minutes
Description:
We will be performing a scheduled hardware upgrade on the SLC core routers to support increased network demand and capacity requirements. This maintenance is necessary to ensure continued performance and reliability of the network.
Impact:
• Brief service interruption affecting traffic traversing the SLC core routers during the maintenance window
Action Required:
No customer action is required. Network teams will monitor the upgrade and restore services immediately upon completion.